树莓派4B 更新wiringPi库到2.52的方法

2020年3月30日17:02:11 发表评论 107 次浏览

最新发布的树莓派4B在烧录了官方系统buster以后,如果直接使用gpio readall去查看GPIO会出现错误。无法识别的情况,需要根据以下步骤进行wiringPi的更新:

cd /tmp

wget https://project-downloads.drogon.net/wiringpi-latest.deb

sudo dpkg -i wiringpi-latest.deb

树莓派4B 更新wiringPi库到2.52的方法

然后再使用gpio -v,检查版本信息,确保版本为:2.52即可。

树莓派4B 更新wiringPi库到2.52的方法

然后再执行:gpio readall

树莓派4B 更新wiringPi库到2.52的方法

这时候就可以继续像往常那样使用GPIO的引脚进行编程了。

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 我的微信小程序
  • 我的微信小程序扫一扫
  • weinxin
lichongyang

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: